01_less_strict_index_tests 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. Description: Make index entry tests a little bit less strict, to cope with
  2. slightly different behaviour on various platforms.
  3. Origin: commit, revision id: git-v1:c398d692d1ba6c5fcee26383bfc78f73875de20b
  4. Author: Jelmer Vernooij <jelmer@samba.org>
  5. Last-Update: 2012-04-02
  6. Applied-Upstream: merged in revision 1044
  7. X-Bzr-Revision-Id: git-v1:c398d692d1ba6c5fcee26383bfc78f73875de20b
  8. === modified file 'dulwich/tests/test_index.py'
  9. --- old/dulwich/tests/test_index.py 2012-03-29 00:21:54 +0000
  10. +++ new/dulwich/tests/test_index.py 2012-04-02 11:05:18 +0000
  11. @@ -26,7 +26,6 @@
  12. import shutil
  13. import stat
  14. import struct
  15. -import sys
  16. import tempfile
  17. from dulwich.index import (
  18. @@ -216,15 +215,8 @@
  19. class BuildIndexTests(TestCase):
  20. - def assertReasonableIndexEntry(self, index_entry,
  21. - time, mode, filesize, sha):
  22. - delta = 1000000
  23. - self.assertEquals(index_entry[0], index_entry[1]) # ctime and atime
  24. - self.assertTrue(index_entry[0] > time - delta)
  25. + def assertReasonableIndexEntry(self, index_entry, mode, filesize, sha):
  26. self.assertEquals(index_entry[4], mode) # mode
  27. - if sys.platform != 'nt':
  28. - self.assertEquals(index_entry[5], os.getuid())
  29. - self.assertEquals(index_entry[6], os.getgid())
  30. self.assertEquals(index_entry[7], filesize) # filesize
  31. self.assertEquals(index_entry[8], sha) # sha
  32. @@ -283,8 +275,6 @@
  33. repo.object_store, tree.id)
  34. # Verify index entries
  35. - import time
  36. - ctime = time.time()
  37. index = repo.open_index()
  38. self.assertEquals(len(index), 4)
  39. @@ -292,28 +282,28 @@
  40. apath = os.path.join(repo.path, 'a')
  41. self.assertTrue(os.path.exists(apath))
  42. self.assertReasonableIndexEntry(index['a'],
  43. - ctime, stat.S_IFREG | 0644, 6, filea.id)
  44. + stat.S_IFREG | 0644, 6, filea.id)
  45. self.assertFileContents(apath, 'file a')
  46. # fileb
  47. bpath = os.path.join(repo.path, 'b')
  48. self.assertTrue(os.path.exists(bpath))
  49. self.assertReasonableIndexEntry(index['b'],
  50. - ctime, stat.S_IFREG | 0644, 6, fileb.id)
  51. + stat.S_IFREG | 0644, 6, fileb.id)
  52. self.assertFileContents(bpath, 'file b')
  53. # filed
  54. dpath = os.path.join(repo.path, 'c', 'd')
  55. self.assertTrue(os.path.exists(dpath))
  56. self.assertReasonableIndexEntry(index['c/d'],
  57. - ctime, stat.S_IFREG | 0644, 6, filed.id)
  58. + stat.S_IFREG | 0644, 6, filed.id)
  59. self.assertFileContents(dpath, 'file d')
  60. # symlink to d
  61. epath = os.path.join(repo.path, 'c', 'e')
  62. self.assertTrue(os.path.exists(epath))
  63. self.assertReasonableIndexEntry(index['c/e'],
  64. - ctime, stat.S_IFLNK, 1, filee.id)
  65. + stat.S_IFLNK, 1, filee.id)
  66. self.assertFileContents(epath, 'd', symlink=True)
  67. # Verify no extra files