01_no_urllib3_pypy 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. diff --git a/dulwich/client.py b/dulwich/client.py
  2. index b5f5f804..0db532d0 100644
  3. --- a/dulwich/client.py
  4. +++ b/dulwich/client.py
  5. @@ -60,10 +60,6 @@ except ImportError:
  6. import urllib.request as urllib2
  7. import urllib.parse as urlparse
  8. -import certifi
  9. -import urllib3
  10. -import urllib3.util
  11. -
  12. import dulwich
  13. from dulwich.errors import (
  14. GitProtocolError,
  15. @@ -1260,6 +1256,8 @@ def default_urllib3_manager(config, verify_ssl=True):
  16. :return: `urllib3.ProxyManager` instance for proxy configurations,
  17. `urllib3.PoolManager` otherwise.
  18. """
  19. + import urllib3
  20. + import certifi
  21. proxy_server = user_agent = None
  22. if config is not None:
  23. @@ -1298,6 +1296,7 @@ class HttpGitClient(GitClient):
  24. def __init__(self, base_url, dumb=None, pool_manager=None, config=None,
  25. username=None, password=None, **kwargs):
  26. + import urllib3.util
  27. self._base_url = base_url.rstrip("/") + "/"
  28. self._username = username
  29. self._password = password
  30. diff --git a/dulwich/tests/test_client.py b/dulwich/tests/test_client.py
  31. index eb1ccbea..881fabf5 100644
  32. --- a/dulwich/tests/test_client.py
  33. +++ b/dulwich/tests/test_client.py
  34. @@ -35,8 +35,12 @@ try:
  35. except ImportError:
  36. import urllib.parse as urlparse
  37. -import certifi
  38. -import urllib3
  39. +if '__pypy__' not in sys.modules:
  40. + import certifi
  41. + import urllib3
  42. +else:
  43. + urllib3 = None
  44. + certifi = None
  45. import dulwich
  46. from dulwich import (
  47. @@ -534,12 +538,20 @@ class TestGetTransportAndPath(TestCase):
  48. self.assertTrue(isinstance(c, SSHGitClient))
  49. def test_http(self):
  50. + if '__pypy__' in sys.modules:
  51. + self.skipTest('urllib3 not available for pypy in debian')
  52. +
  53. +
  54. url = 'https://github.com/jelmer/dulwich'
  55. c, path = get_transport_and_path(url)
  56. self.assertTrue(isinstance(c, HttpGitClient))
  57. self.assertEqual('/jelmer/dulwich', path)
  58. def test_http_auth(self):
  59. + if '__pypy__' in sys.modules:
  60. + self.skipTest('urllib3 not available for pypy in debian')
  61. +
  62. +
  63. url = 'https://user:passwd@github.com/jelmer/dulwich'
  64. c, path = get_transport_and_path(url)
  65. @@ -550,6 +562,10 @@ class TestGetTransportAndPath(TestCase):
  66. self.assertEqual('passwd', c._password)
  67. def test_http_no_auth(self):
  68. + if '__pypy__' in sys.modules:
  69. + self.skipTest('urllib3 not available for pypy in debian')
  70. +
  71. +
  72. url = 'https://github.com/jelmer/dulwich'
  73. c, path = get_transport_and_path(url)
  74. @@ -632,6 +648,9 @@ class TestGetTransportAndPathFromUrl(TestCase):
  75. 'prospero://bar/baz')
  76. def test_http(self):
  77. + if '__pypy__' in sys.modules:
  78. + self.skipTest('urllib3 not available for pypy in debian')
  79. +
  80. url = 'https://github.com/jelmer/dulwich'
  81. c, path = get_transport_and_path_from_url(url)
  82. self.assertTrue(isinstance(c, HttpGitClient))
  83. @@ -863,6 +882,11 @@ class LocalGitClientTests(TestCase):
  84. class HttpGitClientTests(TestCase):
  85. + def setUp(self):
  86. + super(HttpGitClientTests, self).setUp()
  87. + if '__pypy__' in sys.modules:
  88. + self.skipTest('urllib3 not available for pypy in debian')
  89. +
  90. @staticmethod
  91. def b64encode(s):
  92. """Python 2/3 compatible Base64 encoder. Returns string."""
  93. @@ -961,6 +985,11 @@ class TCPGitClientTests(TestCase):
  94. class DefaultUrllib3ManagerTest(TestCase):
  95. + def setUp(self):
  96. + super(DefaultUrllib3ManagerTest, self).setUp()
  97. + if '__pypy__' in sys.modules:
  98. + self.skipTest('urllib3 not available for pypy in debian')
  99. +
  100. def assert_verify_ssl(self, manager, assertion=True):
  101. pool_keywords = tuple(manager.connection_pool_kw.items())
  102. assert_method = self.assertIn if assertion else self.assertNotIn
  103. @@ -972,6 +1001,7 @@ class DefaultUrllib3ManagerTest(TestCase):
  104. self.assert_verify_ssl(manager)
  105. def test_config_no_proxy(self):
  106. +
  107. manager = default_urllib3_manager(config=ConfigDict())
  108. self.assert_verify_ssl(manager)