rules 537 B

1234567891011121314151617181920212223242526
  1. #!/usr/bin/make -f
  2. DPKG_EXPORT_BUILDFLAGS = 1
  3. include /usr/share/dpkg/buildflags.mk
  4. %:
  5. dh $* --with python3 --buildsystem=pybuild
  6. override_dh_auto_test:
  7. ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
  8. $(MAKE) check PYTHON=python3
  9. endif
  10. override_dh_auto_clean:
  11. dh_auto_clean
  12. rm -rf build*
  13. rm -f dulwich/*.so dulwich/*.o
  14. override_dh_installdocs:
  15. dh_installdocs -ppython3-dulwich docs/tutorial -X.gitignore -XMakefile
  16. override_dh_strip:
  17. dh_strip -p python3-dulwich
  18. override_dh_installchangelogs:
  19. dh_installchangelogs NEWS