testsuite3 229 B

1234567891011121314
  1. #!/bin/sh
  2. set -e
  3. unset http_proxy
  4. unset https_proxy
  5. rv=0
  6. for py3 in $(py3versions -s); do
  7. echo "========= Running tests with $py3 =========="
  8. if ! $py3 -m unittest dulwich.tests.test_suite; then
  9. rv=1
  10. fi
  11. done
  12. exit $rv