04_s390x 988 B

1234567891011121314151617181920212223242526272829
  1. From: Stefano Rivera <stefanor@debian.org>
  2. Date: Thu, 26 Dec 2019 09:50:33 +0200
  3. Subject: A missed Py_ssize_t conversion for PY_SSIZE_T_CLEAN
  4. Missed in 8f73bc51e2620820fa1d3aa2c109a3aa3fbe5bc8
  5. This was causing misbehaviour on s390x (multiple test failures).
  6. Bug-Debian: https://bugs.debian.org/946854
  7. Bug-Upstream: https://github.com/dulwich/dulwich/issues/735
  8. Forwarded: https://github.com/dulwich/dulwich/pull/736
  9. ---
  10. dulwich/_diff_tree.c | 3 +--
  11. 1 file changed, 1 insertion(+), 2 deletions(-)
  12. diff --git a/dulwich/_diff_tree.c b/dulwich/_diff_tree.c
  13. index 3481ddd..068b4f6 100644
  14. --- a/dulwich/_diff_tree.c
  15. +++ b/dulwich/_diff_tree.c
  16. @@ -198,8 +198,7 @@ static PyObject *py_merge_entries(PyObject *self, PyObject *args)
  17. {
  18. PyObject *tree1, *tree2, **entries1 = NULL, **entries2 = NULL;
  19. PyObject *e1, *e2, *pair, *result = NULL;
  20. - Py_ssize_t n1 = 0, n2 = 0, i1 = 0, i2 = 0;
  21. - int path_len;
  22. + Py_ssize_t n1 = 0, n2 = 0, i1 = 0, i2 = 0, path_len;
  23. char *path_str;
  24. int cmp;