rules 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. #!/usr/bin/make -f
  2. CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
  3. CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
  4. CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
  5. LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
  6. # Callable functions to determine the correct PYTHONPATH
  7. pythonpath = $$(ls -d $(CURDIR)/build/lib.*-$(1))
  8. pythonpath_dbg = $$(ls -d $(CURDIR)/build/lib_d.*-$(1) 2>/dev/null || ls -d $(CURDIR)/build/lib.*$(1)-pydebug)
  9. pyflavours = python3$(shell which pypy >/dev/null && echo -n ,pypy)
  10. %:
  11. dh $* --with $(pyflavours) --buildsystem=pybuild
  12. override_dh_auto_build:
  13. dh_auto_build
  14. override_dh_auto_clean:
  15. dh_auto_clean
  16. rm -rf build*
  17. rm -f dulwich/*.so dulwich/*.o
  18. override_dh_auto_test:
  19. ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
  20. $(MAKE) check PYTHON=python3
  21. ifneq (,$(findstring pypy,$(pyflavours)))
  22. $(MAKE) check PYTHON=pypy
  23. endif
  24. endif
  25. override_dh_auto_install:
  26. dh_auto_install
  27. set -ex; for python in $(shell py3versions -r); do \
  28. $$python setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb; \
  29. done;
  30. ifneq (,$(findstring pypy,$(pyflavours)))
  31. pypy setup.py build -b build-pypy install --root=$(CURDIR)/debian/tmp --install-layout deb
  32. rm -rf debian/tmp/usr/lib/pypy/bin
  33. endif
  34. # Install everything excluding the *_d.so debug extensions to python-dulwich and python3-dulwich
  35. dh_install -p python3-dulwich -X"*_d.so" -Xpypy "debian/tmp/usr/lib/python3*/*-packages"
  36. ifneq (,$(findstring pypy,$(pyflavours)))
  37. # Install the pypy files to pypy-dulwich
  38. dh_install -p pypy-dulwich "debian/tmp/usr/lib/pypy/"
  39. endif
  40. override_dh_installdocs:
  41. dh_installdocs -ppython3-dulwich docs/tutorial -X.gitignore -XMakefile
  42. ifneq (,$(findstring pypy,$(pyflavours)))
  43. dh_installdocs -ppypy-dulwich docs/tutorial -X.gitignore -XMakefile
  44. endif
  45. override_dh_strip:
  46. dh_strip -p python3-dulwich --dbgsym-migration='python3-dulwich-dbg (<< 0.16.4-1)'
  47. ifneq (,$(findstring pypy,$(pyflavours)))
  48. dh_strip -p pypy-dulwich
  49. endif
  50. override_dh_installchangelogs:
  51. dh_installchangelogs NEWS