02_newer_git 847 B

123456789101112131415161718
  1. Description: Fix compatibility with newer versions of git, which expect CONTENT_LENGTH to be set to 0 for empty body requests.
  2. Origin: commit, revision id: git-v1:76ea02025eb4651913f9cf21454562d572ef4f3d
  3. Author: Jelmer Vernooij <jelmer@jelmer.uk>
  4. Last-Update: 2018-09-05
  5. X-Bzr-Revision-Id: git-v1:76ea02025eb4651913f9cf21454562d572ef4f3d
  6. === modified file 'dulwich/tests/compat/test_client.py'
  7. --- old/dulwich/tests/compat/test_client.py 2018-06-15 22:19:41 +0000
  8. +++ new/dulwich/tests/compat/test_client.py 2018-09-05 20:17:23 +0000
  9. @@ -500,6 +500,7 @@
  10. data = self.rfile.read(nbytes)
  11. else:
  12. data = None
  13. + env['CONTENT_LENGTH'] = '0'
  14. # throw away additional data [see bug #427345]
  15. while select.select([self.rfile._sock], [], [], 0)[0]:
  16. if not self.rfile._sock.recv(1):