02_cgit_c 454 B

123456789101112
  1. diff --git a/dulwich/tests/compat/utils.py b/dulwich/tests/compat/utils.py
  2. index 5142169..d6d1f7f 100644
  3. --- a/dulwich/tests/compat/utils.py
  4. +++ b/dulwich/tests/compat/utils.py
  5. @@ -124,6 +124,7 @@ def run_git(args, git_path=_DEFAULT_GIT, input=None, capture_stdout=False,
  6. """
  7. env = get_safe_env(popen_kwargs.pop('env', None))
  8. + env['LC_ALL'] = env['LANG'] = 'C'
  9. args = [git_path] + args
  10. popen_kwargs['stdin'] = subprocess.PIPE