01_no_urllib3_pypy 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. === modified file 'dulwich/tests/compat/test_client.py'
  2. --- old/dulwich/tests/compat/test_client.py 2018-11-05 19:27:24 +0000
  3. +++ new/dulwich/tests/compat/test_client.py 2018-11-05 19:33:10 +0000
  4. @@ -544,6 +544,8 @@
  5. min_git_version = (1, 7, 0, 2)
  6. def setUp(self):
  7. + if '__pypy__' in sys.modules:
  8. + self.skipTest('urllib3 not available for pypy in debian')
  9. CompatTestCase.setUp(self)
  10. DulwichClientTestBase.setUp(self)
  11. self._httpd = HTTPGitServer(("localhost", 0), self.gitroot)
  12. === modified file 'dulwich/tests/test_client.py'
  13. --- old/dulwich/tests/test_client.py 2018-11-05 19:27:24 +0000
  14. +++ new/dulwich/tests/test_client.py 2018-11-05 19:33:35 +0000
  15. @@ -35,7 +35,8 @@
  16. except ImportError:
  17. import urllib.parse as urlparse
  18. -import urllib3
  19. +if '__pypy__' not in sys.modules:
  20. + import urllib3
  21. import dulwich
  22. from dulwich import (
  23. @@ -550,12 +551,20 @@
  24. self.assertTrue(isinstance(c, SSHGitClient))
  25. def test_http(self):
  26. + if '__pypy__' in sys.modules:
  27. + self.skipTest('urllib3 not available for pypy in debian')
  28. +
  29. +
  30. url = 'https://github.com/jelmer/dulwich'
  31. c, path = get_transport_and_path(url)
  32. self.assertTrue(isinstance(c, HttpGitClient))
  33. self.assertEqual('/jelmer/dulwich', path)
  34. def test_http_auth(self):
  35. + if '__pypy__' in sys.modules:
  36. + self.skipTest('urllib3 not available for pypy in debian')
  37. +
  38. +
  39. url = 'https://user:passwd@github.com/jelmer/dulwich'
  40. c, path = get_transport_and_path(url)
  41. @@ -566,6 +575,9 @@
  42. self.assertEqual('passwd', c._password)
  43. def test_http_auth_with_username(self):
  44. + if '__pypy__' in sys.modules:
  45. + self.skipTest('urllib3 not available for pypy in debian')
  46. +
  47. url = 'https://github.com/jelmer/dulwich'
  48. c, path = get_transport_and_path(
  49. @@ -577,6 +589,9 @@
  50. self.assertEqual('blah', c._password)
  51. def test_http_auth_with_username_and_in_url(self):
  52. + if '__pypy__' in sys.modules:
  53. + self.skipTest('urllib3 not available for pypy in debian')
  54. +
  55. url = 'https://user:passwd@github.com/jelmer/dulwich'
  56. c, path = get_transport_and_path(
  57. @@ -588,6 +603,10 @@
  58. self.assertEqual('passwd', c._password)
  59. def test_http_no_auth(self):
  60. + if '__pypy__' in sys.modules:
  61. + self.skipTest('urllib3 not available for pypy in debian')
  62. +
  63. +
  64. url = 'https://github.com/jelmer/dulwich'
  65. c, path = get_transport_and_path(url)
  66. @@ -670,6 +689,9 @@
  67. 'prospero://bar/baz')
  68. def test_http(self):
  69. + if '__pypy__' in sys.modules:
  70. + self.skipTest('urllib3 not available for pypy in debian')
  71. +
  72. url = 'https://github.com/jelmer/dulwich'
  73. c, path = get_transport_and_path_from_url(url)
  74. self.assertTrue(isinstance(c, HttpGitClient))
  75. @@ -901,6 +923,11 @@
  76. class HttpGitClientTests(TestCase):
  77. + def setUp(self):
  78. + super(HttpGitClientTests, self).setUp()
  79. + if '__pypy__' in sys.modules:
  80. + self.skipTest('urllib3 not available for pypy in debian')
  81. +
  82. @staticmethod
  83. def b64encode(s):
  84. """Python 2/3 compatible Base64 encoder. Returns string."""
  85. @@ -999,12 +1026,18 @@
  86. class DefaultUrllib3ManagerTest(TestCase):
  87. + def setUp(self):
  88. + super(DefaultUrllib3ManagerTest, self).setUp()
  89. + if '__pypy__' in sys.modules:
  90. + self.skipTest('urllib3 not available for pypy in debian')
  91. +
  92. def test_no_config(self):
  93. manager = default_urllib3_manager(config=None)
  94. self.assertEqual(manager.connection_pool_kw['cert_reqs'],
  95. 'CERT_REQUIRED')
  96. def test_config_no_proxy(self):
  97. +
  98. manager = default_urllib3_manager(config=ConfigDict())
  99. self.assertNotIsInstance(manager, urllib3.ProxyManager)