01_refs_unicode 632 B

12345678910111213
  1. diff --git a/dulwich/tests/test_refs.py b/dulwich/tests/test_refs.py
  2. index 3a645c6..61547a1 100644
  3. --- a/dulwich/tests/test_refs.py
  4. +++ b/dulwich/tests/test_refs.py
  5. @@ -441,7 +441,7 @@ class DiskRefsContainerTests(RefsContainerTests, TestCase):
  6. def test_non_ascii(self):
  7. try:
  8. encoded_ref = u'refs/tags/schön'.encode(sys.getfilesystemencoding())
  9. - except UnicodeDecodeError:
  10. + except UnicodeEncodeError:
  11. raise SkipTest("filesystem encoding doesn't support special character")
  12. p = os.path.join(self._repo.path, 'refs', 'tags', 'schön')
  13. with open(p, 'w') as f: